airtraffic

Author Topic: Error installing feed onto Raspberry Pi3b  (Read 462 times)

Offline glennblum

  • Newbie
  • *
  • Posts: 4
Error installing feed onto Raspberry Pi3b
« on: September 30, 2019, 08:11:27 PM »
When installing AIRBAND feeder on my raspberry Pi3b (Raspian Stretch, WIFI enabled full edition) I get the following errors while installing. Pictures shown.
Its probably part of this portion which should be clairfied for users who are not completely knowledgable but have some knowledge of Linux.

Log in to your Pi as user pi, then:
cd /home/pi/RTLSDR-Airband
sudo make clean

* if you are building for RPi V1 type: PLATFORM=rpiv1 make
* if you are building for RPi V2 type: PLATFORM=rpiv2 make


when performing the sudo make clean do you add the following to the same command line?   PLATFORM=rpiv2 make? or sudo make clean  PLATFORM=rpiv2 make? When I googled this problem I have seen other posted in other forums the same problem.



Offline dave

  • Site Founder
  • Administrator
  • Hero Member
  • *****
  • Posts: 4362
    • LiveATC.net
Re: Error installing feed onto Raspberry Pi3b
« Reply #1 on: September 30, 2019, 08:55:15 PM »
Looks like you used your own SD card distribution and not the recommended LiveATC one. The issue is that you are missing the prerequisites for RTLSDT-Airband.

Issue these commands:

sudo apt-get install build-essential libmp3lame-dev libshout3-dev libconfig++-dev libraspberrypi-dev libfftw3-dev
sudo apt-get install libogg-dev libvorbis-dev

then continue to follow the instructions.

Offline glennblum

  • Newbie
  • *
  • Posts: 4
Re: Error installing feed onto Raspberry Pi3b
« Reply #2 on: September 30, 2019, 10:34:27 PM »
It helped a little bit.
I cant use the sd card image. There is no provision for wifi configuration and I can't run a cable to my Pi.

Offline gtheall

  • Newbie
  • *
  • Posts: 3
Re: Error installing feed onto Raspberry Pi3b
« Reply #3 on: October 02, 2019, 08:04:55 PM »
Looks like you are missing the rtl-sdr library, which is listed in https://github.com/szpajder/RTLSDR-Airband/wiki/Dependencies as an optional dependency and needed for working with RTLSDR dongles.

You should be able to install it by running :

sudo apt-get install librtlsdr-dev

Once installed, you should end up with rtl-sdr.h in /usr/include and librtlsdr.a in /usr/lib/arm-linux-gnueabihf (plus other files).

George


Offline glennblum

  • Newbie
  • *
  • Posts: 4
Re: Error installing feed onto Raspberry Pi3b
« Reply #4 on: October 05, 2019, 06:39:03 PM »
After having a few hour's time to go back and recompile my Live ATC feed is now up and running under KGRK2 Killeen Forth Hood regional airport.