Author Topic: SoapySDR with SDRPlay RSP1A - weak signal only  (Read 333 times)

Offline thowe

  • Newbie
  • *
  • Posts: 4
  • Swiss airband fan for many years.
SoapySDR with SDRPlay RSP1A - weak signal only
« on: May 02, 2021, 11:41:30 AM »
I have been a LiveATC feeder for our airport for years and have worked a lot with RTL sticks. Basically good, but now I wanted to try something with a larger dynamic range. So I set up a trial run on an Asus Tinker board and the SDRPlay RSP1A.

Basically everything works end-to-end and I could feed like this. However, I am not satisfied with the quality. The signals are much weaker and noisier than with the RTL dongles. I know that RSP1A can do a lot better when I use it with SDRUno - here the signal is just perfect and strong. Not so with SoapySDR - where it is quite weak and noisy.

Since SoapySDR is new territory for me, I suspect suboptimal settings e.g. in the area of gains or similar.

Can anyone give me tips on how to get good results with RTLSDR_Airband and the SDRPlay device? Have I overlooked something?

Versions:

Armbian: Linux tinkerboard 5.10.21-rockchip #21.02.3
SDRplay_RSP_API-ARM32-3.07.2
SoapySDR 0.8.0
RTLSDR_Airband 3.2.1

Many thanks & best regards
Tom



Offline om3wuc

  • Newbie
  • *
  • Posts: 1
Re: SoapySDR with SDRPlay RSP1A - weak signal only
« Reply #1 on: May 09, 2021, 03:56:21 AM »
Seems Sdrplay devices have poor Linux support. I'm using RSP1a with Windows only, for RPi is RTL-SDR much better. If you want a wider frequency or dynamic range for rtl_airband, use Airspy. I've tried everything but got the same results as you.
« Last Edit: May 09, 2021, 03:58:51 AM by om3wuc »

Offline thowe

  • Newbie
  • *
  • Posts: 4
  • Swiss airband fan for many years.
Re: SoapySDR with SDRPlay RSP1A - weak signal only
« Reply #2 on: May 10, 2021, 03:22:13 PM »
I got some valuable advice in the GitHub discussions at rtlsdr_airband.

The gain must be specified with the RSP1A as follows:
gain = "IFGR=40,RFGR=4";

Explanations of the values can be found here and elsewhere: https://github.com/pothosware/SoapySDRPlay2/issues/60

Further I sampled with 8.0 MSPS (8 MHz bandwidth). This is much more than the usual 2.5 MHz for RTL dongles. Therefore the FFT size must be adjusted, otherwise the single channels become too wide (side channels audible, too much noise).
E.g. adjust with the global option (default is 512):
fft_size = 2048;

With this I now get quite good audio streams. I will test this further and compare it with the AirSpy Mini I have.